PyQt5 Install

pyqt 5 install on osx

11.09.2015

Introduction

PyQt is a set of Python bindings for the C++ Qt application framework. It is a powerful framework for creating cross-platform GUI applications, and much more. PyQt4 is easily installed via conda, but I discovered that there were some annoying visual inconsistencies on OSX, such as the text on these buttons shown below. The left window is using python2.7 and PyQt4. Installing a newer version of PyQt seemed to fix the issue. I have documented the installation process below.

Installation

I used the following steps to install PyQt5 on Mac OSX Yosemite 10.10.5

  1. Download and install the Anaconda package management system.

  2. Create a new conda environment with a Python3.4 interpreter. From what I understand, PyQt5 requires Python version 3.4.

    conda create -n qt5python3 python=3.4

  3. Enter the newly created environment and install PyQt.

source activate qt5python3 conda install -c https://conda.anaconda.org/dsdale24 pyqt5

  1. Test the installation.
import PyQt5